查看: 1954|回复: 0

iPhone X手机偶尔无基带wifi 故障维修

[复制链接]

1249

主题

1325

帖子

4330

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
4330
发表于 2020-7-16 16:57:30 | 显示全部楼层 |阅读模式

接到客户一台iPhone X不开机。客户描述,是浸液导致,有2天多时间了,期间有插充电器充过电,接手后,拆机发现内部的确有浸液,而且还未干.主板这边无明显浸液.主要在电池上。


image.png


电子产品浸液未清洗之前,不得通电检测,先拆下主板,彻底观察后,发现背部有浸液,但不严重,先分层清洗再通电测试(修iPhone X手工一定要过硬,至少分层要练的和拆个屏幕一样随意)。


image.png


之前没太仔细看,分层后发现,是个二修机,中框连接层未发现掉点,以前是修了什么呢,未跟客户沟通,先自行检查吧,查看内部还是没有浸液痕迹的,保险起见,还是用洗板水全板洗了一遍,上测试架测试。


image.png


裸板能开机了,电流顺序为60mA跳变至100mA定住长达10秒左右,然后再走开机电流.开机时间也比较久,之前说到不开机,是因为听筒排线浸液故障导致,这里带过,重点讲本次案例故障。


image.png


进入桌面后,输入密码卡死不动,偶尔会出现尝试恢复数据,进度条走的长度不等,重启然后会出现右上角三角形无基带。

偶尔输入密码可以进入桌面,关键故障来了,经过几次重启,发现了两点奇怪的现象,在能进桌面的情况下,偶尔出现无wifi偶尔出现无基带,两者从不同时出现,这里因为时间紧要,忘记拍照了,只拍了崩溃日志分析。


image.png


观察方法用过之后,说实话看到是这个故障,我头都大了,目前总结如下:

开机定10mA长达10秒

开机偶尔无基带

开机偶尔无wifi.

电池电量显示不对,充电电流不对.(顶住压力,自信的以为是无电池数据引起)

到底先从哪里下手?现在X的案例越来越少,更何况这种二修离奇故障,说了这么多,总算找出所有症状了,下面开始排查,一开始走了弯路,以为故障出现在逻辑面这边,换了充电IC和U2后来发现不是,把中层连接点相关的焊点全部测了一遍,发现S55脚I2S_BB_TO_AP_DIN阻值只有70,为了保险起见,特地找了两块高通板过来测量对比,正常的有450多,用鑫智造查点位.直通基带内部Y5脚。


image.png


按平常修6 7 8代这类主板,这种情况,要么板层短路,要么基带挂了,但是这个偶尔还能出现基带,而且基带出现信号也是正常的,这一路是基带CPU的I2S总线到CPU的数据输入信号,可能浸液到中层和下层连接点了,导致S55脚跟旁边的GND导通了。

中框能不动尽量不动它,为了后期机器稳定,这里我的办法是,加入少量焊油到缝隙旁边,风枪370度,风速38加热中框使中下层连接焊点融锡,重新归位,事实证明,着实这招有效,可靠在拖锡,植锡贴合后依旧稳定。

做完这些操作后,先把中上两层锡拖平,上测试架测试,一切正常了,输入密码就进入桌面wifi和基带都有,充电问题只能贴合测试了,事实又证明,我的自信是正确的。


image.png


image.png


image.png


到此故障完美修复。

回复

使用道具 举报

QQ|Archiver|手机版|小黑屋|ZXW维修案例平台

GMT+8, 2021-4-11 18:47 , Processed in 0.058236 second(s), 19 queries .

Powered by Discuz! X3.4

© 2001-2021 Comsenz Inc.

快速回复 返回顶部 返回列表